AccueilFrChercher

Un type de médias (media type en anglais)[1], à l'origine (et toujours communément) appelé type MIME, est un identifiant de format de données sur internet en deux parties.

Les types de médias étaient à l'origine définis dans la RFC 2046[2] (publiée en ) pour leur utilisation dans les courriels à travers le protocole SMTP, mais ils ont été étendus à d'autres protocoles comme le HTTP ou le SIP dans la RFC 6838[3] (publiée en ).

Un type de médias est composé d'au moins deux parties : un type et un sous-type structuré en arbre avec un suffixe optionnel, et de paramètres optionnels :

type "/" [arbre "."] sous-type ["+" suffixe] *[";" paramètre]

L'IANA définit actuellement les dix types suivants : application, audio, example, font, image, message, model, multipart, text et video, ainsi que les quatre arbres de sous-type suivants : arbre standard (sans préfixe), arbre éditeur (préfixe vnd.), arbre personnel (préfixe prs.) et arbre non enregistré (préfixe x.).

Par exemple, le type de médias text/html; charset=UTF-8 est composé du type text, du sous-type html de l'arbre standard et du paramètre optionnel charset=UTF-8.

D'après la RFC 6838[3], l'utilisation de la catégorie de sous-type non enregistré (préfixe x.) est fortement déconseillée. De plus les sous-types préfixés par x- ou X- ne sont plus considérés comme appartenant à cette catégorie.

Liste des types de média courants

L'IANA entretient un registre des types de médias et des codages de caractères.

Quelques-uns des types de médias les plus courants sont listés ci-après :

  • Type application : fichiers pluri-usages.
    • application/EDI-X12 : données EDI ANSI ASC X12 ; défini dans la RFC 1767[4].
    • application/EDIFACT : données EDI EDIFACT ; défini dans la RFC 1767[4].
    • application/javascript : JavaScript ; défini dans la RFC 4329[5].
    • application/octet-stream : flux de données arbitraire. Considéré comme le format « par défaut » dans plusieurs OS, souvent utilisé pour identifier des fichiers exécutables, ou de type inconnu, ou des fichiers qui doivent être téléchargés grâce à des protocoles qui ne fournissent pas de champ « content disposition » dans leur en-tête. La RFC 2046[2] le décrit comme un recours pour les sous-types et les types non reconnus.
    • application/ogg : Ogg, un flux de données multimedia, conteneur ; défini dans la RFC 3534[6].
    • application/pdf: Portable Document Format, PDF, utilisé pour les échanges de documents depuis 1993 ; défini dans la RFC 3778[7].
    • application/xhtml+xml : XHTML ; défini dans la RFC 3236[8].
    • application/x-shockwave-flash : fichier Adobe Flash ; documenté par Adobe TechNote tn_4151 et Adobe TechNote tn_16509.
    • application/json : JavaScript Object Notation ; défini dans la RFC 4627[9].
    • application/ld+json : JSON-based Serialization for Linked Data.
    • application/xml : eXtensible Markup Language ; défini dans la RFC 3023[10].
    • application/zip : fichier ZIP.
    • application/vnd.oasis.opendocument.text : texte OpenDocument (enregistré[11]).
    • application/vnd.oasis.opendocument.spreadsheet : feuille de calcul OpenDocument (enregistré[12]).
    • application/vnd.oasis.opendocument.presentation : présentation OpenDocument (enregistré[13]).
    • application/vnd.oasis.opendocument.graphics : graphique OpenDocument (enregistré[14]).
    • application/vnd.ms-excel : fichiers Microsoft Excel (.xls).
    • application/vnd.openxmlformats-officedocument.spreadsheetml.sheet : Office Open XML Workbook (.xlsx) (Format d'enregistrement par défaut sous Microsoft Excel à partir de 2007).
    • application/vnd.ms-powerpoint : fichiers Microsoft Powerpoint (.ppt).
    • application/vnd.openxmlformats-officedocument.presentationml.presentation : Office Open XML Presentation (.pptx) (Format d'enregistrement par défaut sous Microsoft PowerPoint à partir de 2007).
    • application/msword : fichiers Microsoft Word (.doc).
    • application/vnd.openxmlformats-officedocument.wordprocessingml.document : Office Open XML Document (.docx) (Format d'enregistrement par défaut sous Microsoft Word à partir de 2007).
    • application/vnd.mozilla.xul+xml : fichiers Mozilla XUL.
  • Type audio : audio.
  • Type example.
  • Type font.
  • Type image.
  • Type message.
  • Type model : modèle 3D.
  • Type multipart : archive et autres objets composés de plus d'une seule partie.
    • multipart/mixed : MIME courriel ; défini dans la RFC 2045[16] et la RFC 2046[2].
    • multipart/alternative : MIME courriel ; défini dans la RFC 2045[16] et la RFC 2046[2].
    • multipart/related : MIME courriel ; défini dans la RFC 2387[22] et utilisé par MHTML (HTML mail).
  • Type text : texte lisible par un être humain ou code source.
  • Type video : vidéo.
    • video/mpeg : MPEG-1, vidéo avec son multiplexé ; défini dans la RFC 2045[16] et la RFC 2046[2].
    • video/mp4 : vidéo MP4 ; défini dans la RFC 4337[27].
    • video/quicktime : vidéo QuickTime ; enregistré[28].
    • video/x-ms-wmv : Windows Media Video ; documenté par (en) « Microsoft KB 288102 » (version du 26 novembre 2013 sur Internet Archive).
    • video/x-msvideo : vidéo dans un conteneur AVI.
    • video/x-flv : Flash Video (FLV) par Adobe Systems.
    • video/web: basé sur un conteneur dérivé Matroska.

Liste des types en évaluation

  • Type application : fichiers pluri-usages.
    • application/x-javascript : En évaluation.

Notes et références

  1. ↑ « Internet Media Type registration, consistency of use », W3C, (consulté le ).
  2. 1 2 3 4 5 6 7 8 (en) Request for comments no 2046
  3. 1 2 (en) Request for comments no 6838
  4. 1 2 (en) Request for comments no 1767
  5. 1 2 (en) Request for comments no 4329
  6. ↑ (en) Request for comments no 3534
  7. ↑ (en) Request for comments no 3778
  8. ↑ (en) Request for comments no 3236
  9. ↑ (en) Request for comments no 4627
  10. 1 2 (en) Request for comments no 3023
  11. ↑ http://www.iana.org/assignments/media-types/application/vnd.oasis.opendocument.text
  12. ↑ http://www.iana.org/assignments/media-types/application/vnd.oasis.opendocument.spreadsheet
  13. ↑ http://www.iana.org/assignments/media-types/application/vnd.oasis.opendocument.presentation
  14. ↑ http://www.iana.org/assignments/media-types/application/vnd.oasis.opendocument.graphics
  15. ↑ (en) Request for comments no 3003
  16. 1 2 3 4 5 (en) Request for comments no 2045
  17. ↑ http://msdn.microsoft.com/en-us/library/ie/ms775147%28v=vs.85%29.aspx#_replace
  18. ↑ http://www.iana.org/assignments/media-types/image/png
  19. ↑ (en) Request for comments no 3302
  20. ↑ http://www.iana.org/assignments/media-types/image/vnd.microsoft.icon
  21. ↑ « Any2DjVu Server », sur djvu.org (consulté le ).
  22. ↑ (en) Request for comments no 2387
  23. ↑ (en) Request for comments no 2318
  24. ↑ (en) Request for comments no 4180
  25. ↑ (en) Request for comments no 2854
  26. ↑ (en) Request for comments no 3676
  27. ↑ (en) Request for comments no 4337
  28. ↑ http://www.iana.org/assignments/media-types/video/quicktime

Liens externes